Minimum System Requirements

Minimum System Requirements

Minimum System Requirements

To continue to protect your data to the highest standard, from early 2018 TLS 1.2 will be required to access Citibank Online and Citi Mobile App via your smartphone, tablet and desktop. Please ensure that your browser and operating systems meet the minimum requirements found below. You will need to update or upgrade your browser / operating system in order to continue to use Citibank Online and the Citi Mobile App.

Minimum browser and operating sysytem requirements.

Web
Browser /
OS:
Desktop Mobile Phones
Windows Mac OS Windows Phone IOS Android
7 8 8.1 10
Preview
10 XP SP3 X X 10.9 X 10.10 X 10.12 8.1 10 5.1.1 4.4.2*
Internet
Explorer 11
X X X X
Chrome 30 X
Chrome 34 X
Chrome 49 X
Firefox 27 X
Firefox 29 X
Firefox 31.3.0 ESR X
Firefox 49 X
Safari 5 X
Safari 7 X
Safari 8 X
Safari 10 X
Opera 17 X
Edge 12 X
Edge 13 X


*All Web Browsers on Android 4.4.2 and up are supported TLS 1.2

NOTE: We do not recommend that you download beta versions, since they are experimental and may undergo significant changes before they're released. Please only download the final version.

How can I tell which browser version I am using?

Depending on the type of browser you are using you can determmine the version in your browser under:

For Windows Users:

  •    -    Microsoft® Internet Explorer™ - Menu > Help >
    About Internet Explorer
  •    -    Mozilla Firefox - Menu > Help >
    About Mozilla Firefox
  •    -    Google Chrome - Wrench icon, top right corner >
    About Google Chrome

For Mac Users:

  •    -    Safari - Safari > About Safari

If you do not update your browser or operationg systems by early 2018, you will not be able to connect to Citibank Online or use Citi Mobile App and will be presented with the following error page for example:


page not displayed